Some Sidequest users are not being subscribed to task threads
Incident Report for Sidequest
Resolved
We have updated Sidequest to make sure all users are automatically notified as soon as a task thread receives an update. Thank you very much for your patience!

By the way: all your users can always customize the amount of notifications that they want to receive in their Personal Settings, right from the Sidequest Home Tab.
Posted Oct 04, 2021 - 12:13 UTC
Identified
We have identified the root cause for this issue, which is an unannounced change in the behavior of the Slack API. We are currently implementing the respective modifications on our end to make sure that the behavior will be back to what you expect.
Posted Oct 04, 2021 - 10:07 UTC
Investigating
We are investigating an issue that results in users not being subscribed to Sidequest task threads, and therefore not receiving notifications about status changes and replies. While we investigate this issue, we suggest that you revisit pending tasks regularly or manually subscribe to task threads as described at https://slack.com/help/articles/115000769927-Use-threads-to-organize-discussions-#manage-thread-notifications.
Posted Oct 04, 2021 - 08:47 UTC
This incident affected: Sidequest Service.